Supported Versions

The support tables below are for the latest version of the Honeybadger gem, which aims to support all maintained (non-EOL) versions of Ruby and supported frameworks. If you're using an older version of Ruby or your framework, you may need to install an older version of the gem.

Supported Ruby Versions

Ruby Interpreter Supported Version
MRI >= 2.7.0
JRuby >= 9.2

Supported Web Frameworks

Framework Version Native?
Rails >= 5.2 yes
Sinatra >= 1.2.1 yes
Rack >= 1.0 middleware

Rails and Sinatra are supported natively (install/configure the gem and you're done). For vanilla Rack apps, we provide a collection of middleware that must be installed manually.

To use Rails 2.x, you'll need to use an earlier version of the Honeybadger gem. Go to version 1.x of the gem docs.

Supported Job Queues

Library Version Native?
Sidekiq any yes
Resque any yes
Delayed Job any yes
Sucker Punch any yes
Shoryuken any yes

For other job queues, you can manually call Honeybadger.notify in your error handler. For instance, if you're using GoodJob:

ruby
config.good_job.on_thread_error = do |ex| Honeybadger.notify(ex) end

Other Integrations

Library Version Native? Description
Devise/Warden any yes Exceptions are automatically associated with the current user.
Thor any yes Exceptions in commands are automatically reported.

You can also integrate Honeybadger into any Ruby script using Honeybadger.notify. See the API reference for a full list of methods available.